Jump to content

Huntsmen Run away backwards after spawning

Closed 1.3.1

Hi.  Since the February update, when the huntsmen spawn they immediately start running backwards away from where the animal died.  They run for a long time and you have to chase them to kill them.  I haven't changed any of the other NPC plugins that I was using before the wipe.

  • Like 1

Share this comment


Link to comment

True i have already reported this issue, getting "invisible" huntsmen now where i get the warning message  that a huntsman has spawned  and a warning that "an enemy is close" (proximity alert plugin) but no sign of the huntsman,  i also now get a weird effect of a laser sight light shining around or close to me but no shots fired, the weird thing is that none of the huntsmen have a laser sight equipped but i can see one shining at me when i do encounter a Huntsman but there is nothing on the weapon in the kit ?

 

** Just noticed this in console when Huntsman did not appear

[Huntsman] acebaby12 shot down a bear[33000174] and a HuntsMan tried to arrest him/her

Failed to create agent because it is not close enough to the NavMesh

assets/rust.ai/agents/npcplayer/humannpc/scientist/scientistnpc_roam.prefab failed to sample navmesh at position (-1696.2, 17.9, -345.5) on area: HumanNPC

[Nav Mesh Error Fix] Located & Killed Stuck assets/rust.ai/agents/npcplayer/humannpc/scientist/scientistnpc_roam.prefab at (-1696.2, 17.9, -345.5)

assets/rust.ai/agents/npcplayer/humannpc/scientist/scientistnpc_roam.prefab failed to sample navmesh at position (-1696.2, 17.9, -345.5) on area: HumanNPC

"SetDestination" can only be called on an active agent that has been placed on a NavMesh.

 

BUT i actually shot another bear just before that right next to the first bear and the Huntsman appeared (although he ran a fair distance away)

Edited by pookins

Share this comment


Link to comment

Any update on this as i have the same issue and have since removed this plugin as its useless till this is fixed.  They have been having issues with shooting and when spawned they run backwards and keep running.

Share this comment


Link to comment
21 minutes ago, PrimeCraze said:

Any update on this as i have the same issue and have since removed this plugin as its useless till this is fixed.  They have been having issues with shooting and when spawned they run backwards and keep running.

I still use it as approx 3/10 dont appear (navemesh issue) 3/10 run sideways/back (fast) and you can sometimes hit/kill them but the other 4/10 work normally and shoot the crap out of you if you are not fast enough.

Share this comment


Link to comment
440.6k

Downloads

Total number of downloads.

2.3k

Customers

Total customers served.

32.5k

Files Sold

Total number of files sold.

530.8k

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.