Jump to content

Gifs chaining site performances - Bad for SEO & Google results


GamingHQ

Recommended Posts

It has come to my attention that more and more users are starting to use a GIF for their plugin uploads as an avatar to promote their plugin or prefab. However, nowadays, it has become a chain for the website, losing its performance as all the gifs need to load in. 

GIFs are bad and a big nogo for SEO. if you oversaturate your page with too many of them, they will simply slow down the site's loading time, and Google takes this into account when ranking pages.

Link to comment
Share on other sites

  • Administrator

The fact it's a gif has very little to do with the size of the payload. We have a pretty strict size restriction on screenshots to prevent large images from affecting the paint speed of our site. In addition, we have three layers of caching as well as serving all static and revolving content via a CDN. This has little impact on our SEO.

Even if it did affect our SEO it's a nice tradeoff as gifs make products far more appealing and allow creators a way to garner more impressions by having engaging thumbnails.

Link to comment
Share on other sites

10 hours ago, Death said:

The fact it's a gif has very little to do with the size of the payload. We have a pretty strict size restriction on screenshots to prevent large images from affecting the paint speed of our site. In addition, we have three layers of caching as well as serving all static and revolving content via a CDN. This has little impact on our SEO.

Even if it did affect our SEO it's a nice tradeoff as gifs make products far more appealing and allow creators a way to garner more impressions by having engaging thumbnails.

i really wonder why the website keeps loading time to time for 5 min for a simple image.

Link to comment
Share on other sites

  • Administrator
34 minutes ago, GamingHQ said:

i really wonder why the website keeps loading time to time for 5 min for a simple image.

It's possible you're experiencing a cache miss. That's when the edge cache took too long to respond so an origin call was made, causing the longer paint speeds. I just deployed another bucket to hopefully intercept these misses and prevent your browser from having to wait for origin calls.

Link to comment
Share on other sites

  • 3 months later...

Currently it is actually almost impossible for me to search for plugins because the page takes a very long time to load or hangs up. all other pages work. I have even tried other browsers and still there are problems. I hope they find a solution soonUnbenannt.thumb.png.a091e6029792e1d622e8c26a508a5622.png

Edited by Kobani
Link to comment
Share on other sites

  • Administrator
3 hours ago, Kobani said:

Currently it is actually almost impossible for me to search for plugins because the page takes a very long time to load or hangs up. all other pages work. I have even tried other browsers and still there are problems. I hope they find a solution soon

Check your internet connection or try clearing your browser cache. Also, what country are you connecting from so I can do some local testing on our end?

Link to comment
Share on other sites

9 hours ago, Death said:

Check your internet connection or try clearing your browser cache. Also, what country are you connecting from so I can do some local testing on our end?

I have tried all that. And yes even other browsers, with all the same. Other pages work without problems. I come from Germany

Link to comment
Share on other sites

  • Administrator
21 minutes ago, Kobani said:

I have tried all that. And yes even other browsers, with all the same. Other pages work without problems. I come from Germany

Thanks for that information. So this only happens to you on the plugins page?

Link to comment
Share on other sites

Actually it occurs everywhere, in the discussions, in the search.... the loading sign is displayed and I can't click anything on the page. Right now, for example, I can't do anything. I am trying to reply to you right now. I have to close the browser completely. And then, with luck, it works again. Sometimes it works, then it doesn't. I can't explain it to myself. Because everything else works, Discord, streams, youtube, Netflix, Games, everything without problems. 

Link to comment
Share on other sites

  • Administrator
30 minutes ago, Kobani said:

Actually it occurs everywhere, in the discussions, in the search.... the loading sign is displayed and I can't click anything on the page. Right now, for example, I can't do anything. I am trying to reply to you right now. I have to close the browser completely. And then, with luck, it works again. Sometimes it works, then it doesn't. I can't explain it to myself. Because everything else works, Discord, streams, youtube, Netflix, Games, everything without problems. 

This sounds like you might have some poorly cached JS on your browser. Could you clear your browser cache?

Link to comment
Share on other sites

What about a CDN network? It's a bit of recoding, but it would improve the access to the website big time. for everyone around the globe. 

Then you would have all files you call in your script like cdn.codefling.com/uploads/java...........

 

 

Link to comment
Share on other sites

2 hours ago, Death said:

@Kobani Can you confirm if my above comment has resolved your issues?

Hello, no, nothing has changed until yesterday. 
But I found the problem in my case. 😊 I wanted to wait until today if the problem occurs again with me before I contact you.
The default settings of the FritzBox 7590 for IPv6 kept breaking the page load for me.
I changed them from:
- Use native IPv4 connection
to:
- Use IPv6 connection with tunnel protocol

Since then it works again without problems.
Maybe this will help those who have the same problem.
Thank you very much for your effort. 

Link to comment
Share on other sites

  • 2 months later...
  • Administrator

@GamingHQ I just checked, and the entire plugin's page is 5 MB. Your problem isn't the GIFs lol. We do have new image processing so if you do see some products without an image it's because it's either too large or a bad format.

image.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1.1m

Downloads

Total number of downloads.

5.8k

Customers

Total customers served.

84.4k

Files Sold

Total number of files sold.

1.6m

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.