Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
KingSizeKevin

Lighthouse NPC won't spawn

Pending 2.1.2

[BotSpawn] Can't get spawn point at Lighthouse 1. Skipping one npc.

 

I get spammed with this in console constantly.  This is the 3rd seed in a row this happened so its on multiple procedural maps.

 

Share this comment


Link to comment

Hi Kevin,

As is the case with the Dome and some other monuments, the lighthouse itself gets in the way when looking for random spawn points.
Try increasing the spawn radius for that profile, or using custom spawn points.

Share this comment


Link to comment

I have moved the radius of that monument from 120-130-140 now at 150 and i am still getting that same error message for that same lighthouse, all other monuments are good. its surprising as we are for sure on different maps 🙂 and now updated to 2.1.5 (thanks for the time fix all my nighttime bots were out in the day)

 

Edit , thought the nighttime numbers spawning in the day was fixed but it only lasted one game day after that they are still hanging around after daytime (0900) started. checked at 12noon and they are still there

Edited by pookins
still not fixed
  • Like 1

Share this comment


Link to comment

ugh, really?
Ok, I'll have a look this evening.

I made some changes to how custom spawn points are handled and it's had a few knock-on effects.
Thanks for letting me know.

Depending on the terrain around the lighthouse it may be very difficult to get random spawn points.
In some cases custom spawn points may be necessary but they auto-migrate at wipe now (if you set Parent_Monument correctly before adding points)
so at least it only needs done once.

Edited by Steenamaroo

Share this comment


Link to comment
19 hours ago, Steenamaroo said:

ugh, really?
Ok, I'll have a look this evening.

I made some changes to how custom spawn points are handled and it's had a few knock-on effects.
Thanks for letting me know.

Depending on the terrain around the lighthouse it may be very difficult to get random spawn points.
In some cases custom spawn points may be necessary but they auto-migrate at wipe now (if you set Parent_Monument correctly before adding points)
so at least it only needs done once.

Thanks for the quick response, just had a few tries and set the Radius from the sublime (30) to the ridiculous (200) and still the same problem , BUT only with lighthouse 1  ??  is there something new in the .cs file that only seems to effect this monument as i have seen other threads regarding this same lighthouse (all on different maps)

BTW. Have a nice Easter and keep away from the Covid

Share this comment


Link to comment

Thanks man! Same to yourself. 🙂

No, there's nothing different about, or specific to, any single profile.
Any chance you have UseCustomSpawns true and some spawn points that are in the air or underground or something?

With radius as high as 200 it should definitely be finding something, somewhere, unless that's the case ^.

Share this comment


Link to comment

That is what i thought but (?) anyway unloaded BS again and changed it to 205 and then loaded it and didnt find any bots on lighthouse1 , unloaded again and made nighttime numbers 15 reloaded and made it 12am, and the shoreline lit up, this lighthouse is offshore so they all spawned on the shore, i killed them all and then waited for daytime and only five showed up which is normal and no error message, killed them and waiting to see if they spawn on time, hows this for funny , now i am getting the error message that there is not enough room for them to spawn (as above) so will miss out on one bot except i can see 5 bots there ? , i cannot understand it. i have 5day and 15night set up. i got 5 there but its spamming my console about not being able to spam "one" of them ?

252490_20210405230536_1.png

Edited by pookins
add screenshot

Share this comment


Link to comment

Made the radius 215 and still the same. lighthouse is facing a very wide open beach with no obstructions.

RustIO map seed 698005706 *right hand side or just type Pal-ul-don in search bar. and as you can see from the picture above there ARE 5 bots spawned.

 

*been watching spawns and notice that they are still not following nightime/daytime spawn settings , tunnel bots should not be there in the daytime and extra (20) bots per biome at night still there as well, if i reload botspawn they go to config settings but that will only last a few "game" days .

Edited by pookins

Share this comment


Link to comment

"Any chance you have UseCustomSpawns true and some spawn points that are in the air or underground or something?"

Rule that out first.
Personally I'd just use custom spawn points for the lighthouses and harbors.

If you already are then do /botspawn edit "ProfileName" to see where the current spawn points are.

 

As far as I know any respawn/timer/population control issues are resolved in V2.1.6 but I don't think there was ever any issue regarding finding spawn points.
 

Share this comment


Link to comment

This is not a new problem , this has happened a few times in the past and you have always given the advise to expand the spawn radius, I will see if i can find a few examples , pity the umod files are  no longer available .

Share this comment


Link to comment

I'd really need to know if you're using custom spawn points or not.
If you are please use `/botspawn edit <profilename>` to confirm if they are in the correct place.
If you're not, please let me know. 🙂

Share this comment


Link to comment

No custom spawn points at all.

And i have moved the radius out to 250 and still getting the error message even though the bots are cleary visible ?

File Manager > \oxide\data\BotSpawn\default-CustomProfiles.json

{
  "DataProfiles": {},
  "MigrationDataDoNotEdit": {}
}

File Manager > \oxide\data\BotSpawn\default-SpawnsData.json

{
  "CustomSpawnLocations": {
    "Abandoned Cabins 0": [],
    "Abandoned Supermarket 0": [],
    "Abandoned Supermarket 1": [],
    "Abandoned Supermarket 2": [],
    "Airfield 0": [],
    "Bandit Camp 0": [],
    "Giant Excavator Pit 0": [],
    "Harbor 0": [],
    "Harbor 1": [],
    "HQM Quarry 0": [],
    "Launch Site 0": [],
    "Lighthouse 0": [],
    "Lighthouse 1": [],
    "Mining Outpost 0": [],
    "Outpost 0": [],
    "Oxum's Gas Station 0": [],
    "Oxum's Gas Station 1": [],
    "Oxum's Gas Station 2": [],
    "Satellite Dish 0": [],
    "Sewer Branch 0": [],
    "Stone Quarry 0": [],
    "Sulfur Quarry 0": [],
    "The Dome 0": [],
    "Water Treatment Plant 0": [],
    "Wild Swamp 0": [],
    "Wild Swamp 1": [],
    "Junkyard 0": [],
    "Military Tunnel 0": [],
    "Mining Outpost 1": [],
    "Mining Outpost 2": [],
    "Power Plant 0": [],
    "Train Yard 0": [],
    "Fishing Village 0": [],
    "Fishing Village 1": [],
    "Large Fishing Village 0": [],
    "Large Barn 0": [],
    "Ranch 0": [],
    "Train Tunnel 0": [],
    "Train Tunnel 1": [],
    "Train Tunnel 2": [],
    "Train Tunnel 3": [],
    "Train Tunnel 4": [],
    "Train Tunnel 5": [],
    "Train Tunnel 6": [],
    "Train Tunnel 7": [],
    "Train Tunnel 8": [],
    "Train Tunnel 9": []
  }
}

 

its a puzzle   🙂

Share this comment


Link to comment

Might not happen on the next map .  and still having too much fun with the plugin to start playing around with it, its more like a bit of feedback than anything else, as i said i get the message but the bots ARE there, if they were absent i would worry more about it.

Thanks again for a great plugin. 

Share this comment


Link to comment

No worries.
The population control frequently checks if any npcs are missing, or if there are too many, so it could fail to find a suitable spawn point any number of times before finally succeeding.
That's why you'll see message about failure to find points but, eventually, still have npcs there.
 

If you just want them at the coast you'd be better off disabling the lighthouse profile and putting a custom profile on the coast.
If you want npcs around the actual lighthouse then the best way is to use custom spawn points.

Edited by Steenamaroo

Share this comment


Link to comment

About Us

Codefling is a forward-thinking platform for developers to share and monetize their work from plugins to game assets and everything in-between.

2066 files sold to 246 customers and $26890.44 of payments processed this year!

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.