Jump to content

Strange Problem

Closed 1.1.3

Hey there - had a really strange bug happen today on our server.  Placing TC's would break, Recyclers broke at everyones base, teleportation homes lost ownership and anytime someone tried to place a recycler it would break immediately. I unloaded this plugin and everything returned to normal. Not sure what happened

Share this comment


Link to comment

I looked into this some more and I do not see any bit of code that could possibly cause this. the plugin does not intercept anything that is built or deployed by players. hooks that allow this are OnEntityBuilt, OnEntitySpawned and CanBuild. I don't use any of these for that purpose. in fact, nothing is killed in these hooks and CanBuild hook is not used

Edited by nivex

Share this comment


Link to comment
2 hours ago, nivex said:

I looked into this some more and I do not see any bit of code that could possibly cause this. the plugin does not intercept anything that is built or deployed by players. hooks that allow this are OnEntityBuilt, OnEntitySpawned and CanBuild. I don't use any of these for that purpose. in fact, nothing is killed in these hooks and CanBuild hook is not used

Thanks for looking into it.  It seems as if something got all jacked with ownership on entities- at least as far as I can tell.  Unfortunately this has been disabled and haven’t seen the issue since my post.

Share this comment


Link to comment
353.8k

Downloads

Total number of downloads.

1.8k

Customers

Total customers served.

24.4k

Files Sold

Total number of files sold.

379.5k

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.