Jump to content

Rust Rewards not recognising Economics

Closed 3.0.4

I have Economics plugin installed plus Rust Rewards but it isn't recognising Economics is installed and reverts to using scrap every time I change it to Economics as the reward and reload the plugin.

Share this comment


Link to comment

Hi,
I've had a few people saying they've had issues with Economics so I'll fire it up and have a test.
I always tested with SR 'cos I happened to have that installed at the time so, hopefully, I'll find something and let you know.
Thanks for reporting.

Share this comment


Link to comment
1 minute ago, Steenamaroo said:

I should say, make sure that only UseEconomics is true.

If UseScrap or UseServerRewards is also true, it'll cause problems.

I have made sure multiple times that only UseEconomics is set to true, but still every time it reverts back to using scrap.

 

Edit:-

I had Economics installed before I installed Rust Rewards and on first load it didn't detect the Economics plugin

Edited by Smokedawg
  • Like 1

Share this comment


Link to comment

Hi,

I just checked - It's working fine but you'll need to unload the plugin, make the change in config, the load the plugin.
I've changed it so that this wont be the case in future versions - I hadn't realised.

Regarding your console logs, that looks normal.
In the case of a brand new config file "Server Rewards and Ecoomics not found" is actually incorrect reporting,
resulting from all three options being false by default.
I've also fixed that so it should no longer show up on first install / config wipe.

Edited by Steenamaroo

Share this comment


Link to comment

This is exactly whats happening to me right now, I go in the config file set the rewards to economics turn off scrap and rustrewards save file reload plugin and nothing happens, open config back up and its back to default using scrap! like it didn't change any setting after i saved it, i removed economics plugin from the server, reloaded rustrewards then installed economics again but the same thing keeps happening after save and reload it goes back to stock settings!

Share this comment


Link to comment
11 minutes ago, zulg said:

This is exactly whats happening to me right now, I go in the config file set the rewards to economics turn off scrap and rustrewards save file reload plugin and nothing happens, open config back up and its back to default using scrap! like it didn't change any setting after i saved it, i removed economics plugin from the server, reloaded rustrewards then installed economics again but the same thing keeps happening after save and reload it goes back to stock settings!

Never mind i missed the part where you said to unload the plugin then make the changes , then reload the plugin, seems to be ok now!

Share this comment


Link to comment
347.9k

Downloads

Total number of downloads.

1.8k

Customers

Total customers served.

23.7k

Files Sold

Total number of files sold.

368.8k

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.