Jump to content

Failed to create agent because it is not close enough to the NavMesh

No Response 1.0.6

My logfile is spammed full of the error and it make it extremally annoying to go through. went though every Npc spawned with BotReSpawn to remove the broken spawn but all are spawning and moving (except the ones I made stationary). It must be something with it as unloading it makes the error stop but seems not to be related to my spawns strange.

 

Share this comment


Link to comment

Hi,
Sorry you're seeing this issue. I tried to make it very unlikely to happen but it is still possible in certain circumstances.

If unloading the plugin stops it from happening then clicking reload, per profile, should interrupt it, letting you know which profile the problem is coming from.

 

Alternatively, if you're happy sharing your map and data/BotReSpawn folder with me privately, I'd be happy to try to track it down over here.

Edited by Steenamaroo

Share this comment


Link to comment
16 hours ago, Steenamaroo said:

Hi,
Sorry you're seeing this issue. I tried to make it very unlikely to happen but it is still possible in certain circumstances.

If unloading the plugin stops it from happening then clicking reload, per profile, should interrupt it, letting you know which profile the problem is coming from.

 

Alternatively, if you're happy sharing your map and data/BotReSpawn folder with me privately, I'd be happy to try to track it down over here.

After doing what you suggested I got this error on one of the profiles and it didn't interrupt the NavMesh error. At the monument with the profile that gave the error we are setting each one to stationary to track down the broken npc. If I can't find which one I'm happy to send my map and profiles. 

NullReferenceException: Object reference not set to an instance of an object
  at Oxide.Plugins.BotReSpawn.SelectWeapon (HumanNPC npc) [0x000d0] in <005888e6a0d240e599ce36ee1df76c41>:0 
  at Oxide.Plugins.BotReSpawn+BotData.SelectWeapon () [0x00000] in <005888e6a0d240e599ce36ee1df76c41>:0 


Edit: After setting all bots on every profile to stationary the NavMesh error still persist

Edited by rustyspoon23

Share this comment


Link to comment
433.7k

Downloads

Total number of downloads.

2.3k

Customers

Total customers served.

32k

Files Sold

Total number of files sold.

519.5k

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.