Jump to content

High CPU usage

Closed 1.0.2

Hello!

FYI.  On the new version when the plugin is loaded or reloaded, the CPU spikes up to 180%+ continuously for approx 1min. before it gets back down to "idle" of approx 70-80%.  Is this intended?

edit:  Tried both updating the plugin with old config file, then deleting config and installing new as well.  Long CPU spikes on both cases.

Edited by Rockefeller

Share this comment


Link to comment
39 minutes ago, Rockefeller said:

Hello!

FYI.  On the new version when the plugin is loaded or reloaded, the CPU spikes up to 180%+ continuously for approx 1min. before it gets back down to "idle" of approx 70-80%.  Is this intended?

edit:  Tried both updating the plugin with old config file, then deleting config and installing new as well.  Long CPU spikes on both cases.

CPU usage is relative to the server/how many cores. If your server is running 4 cores, then 180% isn't that bad. Your focus should be on server fps.

 

There isn't anything on server load that would run for that duration, except for Image library.

The plugin calculates and builds the player data based on the data file but this usually done in a matter of seconds.

What is your avg server fps?

Share this comment


Link to comment
1 hour ago, imthenewguy said:

CPU usage is relative to the server/how many cores. If your server is running 4 cores, then 180% isn't that bad. Your focus should be on server fps.

 

There isn't anything on server load that would run for that duration, except for Image library.

The plugin calculates and builds the player data based on the data file but this usually done in a matter of seconds.

What is your avg server fps?

FPS is limited to 60.  I didn't see it drop below 57 while the CPU was spiking.

Thats why I thought it was weird.  Every plugin I use will spike some CPU usage on a reload, but this was sustained for approx 60 sec.

Share this comment


Link to comment
19 minutes ago, Rockefeller said:

FPS is limited to 60.  I didn't see it drop below 57 while the CPU was spiking.

Thats why I thought it was weird.  Every plugin I use will spike some CPU usage on a reload, but this was sustained for approx 60 sec.

Odd. I wouldn't think to much about it unless it affects performance. If you are having performance issues (ie if you are high pop), set the following setting to false:

"Use mouse 3 to toggle the boat turbo (performance heavy on high pop servers). Set false to use a chat command instead"

 

Share this comment


Link to comment
433.7k

Downloads

Total number of downloads.

2.3k

Customers

Total customers served.

32k

Files Sold

Total number of files sold.

519.5k

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.