Jump to content

issues on install

Closed 1.1.2 1.1.5

 Failed to call hook 'OnNpcTarget' on plugin 'NPCGrenades v1.1.2' (NullReferenceException: Object reference not set to an instance of an object)
at Oxide.Plugins.NPCGrenades.IsFriend (System.UInt64 playerId, System.UInt64 targetId) [0x0005b] in <9a40ac5111e748928c17da3a80a8fefa>:0
at Oxide.Plugins.NPCGrenades.OnNpcTarget (BaseEntity npc, BasePlayer player) [0x00043] in <9a40ac5111e748928c17da3a80a8fefa>:0
at Oxide.Plugins.NPCGrenades.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x00724] in <9a40ac5111e748928c17da3a80a8fefa>:0
at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <60c318df79ed41688ea59335e48d61ad>:0
at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <9882f28dc2204b4dba514a9ad18f5042>:0
at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <9882f28dc2204b4dba514a9ad18f5042>:0

I deleted all files data, config, and lang and cs and installed and i get this.

Share this comment


Link to comment
1 hour ago, rednekOIO said:
 Failed to call hook 'OnNpcTarget' on plugin 'NPCGrenades v1.1.2' (NullReferenceException: Object reference not set to an instance of an object)
at Oxide.Plugins.NPCGrenades.IsFriend (System.UInt64 playerId, System.UInt64 targetId) [0x0005b] in <9a40ac5111e748928c17da3a80a8fefa>:0
at Oxide.Plugins.NPCGrenades.OnNpcTarget (BaseEntity npc, BasePlayer player) [0x00043] in <9a40ac5111e748928c17da3a80a8fefa>:0
at Oxide.Plugins.NPCGrenades.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x00724] in <9a40ac5111e748928c17da3a80a8fefa>:0
at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <60c318df79ed41688ea59335e48d61ad>:0
at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <9882f28dc2204b4dba514a9ad18f5042>:0
at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <9882f28dc2204b4dba514a9ad18f5042>:0

I deleted all files data, config, and lang and cs and installed and i get this.

Thanks for the report, I can see what the issue is, thanks for the error log. I am just finishing work and will fix and update when I get home. Should be a quick fix, I can see what’s causing the error. The plug-in should be working work fine otherwise am I right? But that error pops up sometimes?

Edited by ZEODE

Share this comment


Link to comment
1 hour ago, rednekOIO said:

not sure if it is, i updated while i was work. and had to delete it due to the spam

New update has fixed this I hope, please let me know if you still have issues though. Thanks for the report.

Share this comment


Link to comment
353.8k

Downloads

Total number of downloads.

1.8k

Customers

Total customers served.

24.4k

Files Sold

Total number of files sold.

379.5k

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.