Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
n00b_eh

Custom Spawn Points

Work in Progress 2.1.0

Hi, I am having trouble using custom spawn points with a custom profile and having them move automatically with a map change.  I have set the Parent_Monument to "Train Yard 0" of my custom profile.  This seems to work, I see a "Parent_Monument change detected" on server startup, but the bots don't spawn at the custom spawn points after I change the map.  The custom spawn points work just fine before the map is changed.  Do I need to create a custom profile for every bot I want to custom spawn?  I am trying to add scientists in the buildings of the monuments to spice things up.

  • Like 1

Share this comment


Link to comment

Hey,

CustomSpawnPoints don't relocate according to Parent_Monument.

It's only the main profile location which relocates, meaning it's only really useful for UseCustomSpawns: false

  • Like 1

Share this comment


Link to comment

Thanks for your reply!  I was afraid of that.  I will have to make a profile for every spawn then and see how that goes.

Your plugin is the only reason I love playing this game!

  • Like 1

Share this comment


Link to comment

It comes up a lot - I'm tempted to make custom spawn points relocate too.

I thought there was a reason I didn't but I can't think what that would have been now. 😂

Share this comment


Link to comment

It would seem to make sense since the custom spawn points are configured to be children of relocatable profiles.  It's a bunch of work though and you have provided another means I think.

Share this comment


Link to comment
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.