Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sth

Botspawn attack HumanNPC

Closed 2.1.0 Next Version

Previously, the Botspawn version did not attack HumanNPC bots - but in version 2.1.0, Botspawn does not ignore HumanNPC and attacks them if they are seen. The config does not respond to changes in behavior between these plugins.

Please fix this issue. Thank you!

Share this comment


Link to comment

{
  "DataPrefix": "default",
  "Global": {
    "DayStartHour": 8,
    "NightStartHour": 20,
    "NPCs_Attack_BotSpawn": false,
    "HTNs_Attack_BotSpawn": false,
    "BotSpawn_Attacks_NPCs": false,              <------------  FALSE - but attack
    "APC_Safe": true,
    "Turret_Safe": true,
    "Animal_Safe": true,
    "Supply_Enabled": true,
    "Remove_BackPacks_Percent": 100,
    "Remove_KeyCard": true,
    "Ignore_HumanNPC": true,                <---------
    "Ignore_HTN": true,
    "Ignore_Sleepers": true,
    "Pve_Safe": false,
    "Max_Chute_Wind_Speed": 100,
    "Max_Chute_Fall_Speed": 100
  }
}

Edited by Sth

Share this comment


Link to comment
6 minutes ago, Steenamaroo said:

Hi,

Thanks for flagging this. Someone else also flagged it a few days ago so the fix is done and tested.
Next update will include it.

That's what I was identified in the discord channel. My server is very closely tied to being in the same location and Botspawn and Humanpc bots. It turns out that the entire concept was destroyed when version 2.1.0 was released.
Please. Hurry up, please. This fix is as important to me as air.
Thank you in advance!

Edited by Sth

Share this comment


Link to comment

I'm not sure 2.1.0 has anything to do with it.
The HumanNPC check I'm using was in a HumanNPC fork - not the copy on uMod.

 

Are you certain that it worked for you recently? If so, were you using RFC's copy of HumanNPC then switched to the uMod version?

Share this comment


Link to comment
9 hours ago, Steenamaroo said:

I'm not sure 2.1.0 has anything to do with it.
The HumanNPC check I'm using was in a HumanNPC fork - not the copy on uMod.

 

Are you certain that it worked for you recently? If so, were you using RFC's copy of HumanNPC then switched to the uMod version?

v0.3.43 - umod
Only (latest)

Edited by Sth

Share this comment


Link to comment

I don't see a way HumanNPC detection would have worked with uMod HumanNPC over the last, maybe, 10 versions of BotSpawn

but no matter : The file attached in the link thread fixes the issue, and I'll push a public update fairly soon.

Thanks again for letting me know.

Edited by Steenamaroo

Share this comment


Link to comment
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.