Jump to content

still raidable

Closed 1.0.70

attached are my settings. essentially what i want to happen is:

no player to building, no fire to building, no player to palyer, no fire to player.... essentially a PVE environment

but it seems iffy because some players are still able to raid and i did some testing and the following is happening:

- can damage stone

- can damage hqm

- can damage metal

- can't damage twig, wood

i tested with explosives ammo, rocket, c4 --- does not damage wood/twig
but wood/ twig gets damaged by fire, the stone gets damaged by bullets

sorry so confused with this ūüėě

nextgenpve.PNG

nextgenpve1.PNG

Share this comment


Link to comment

ok i found this, but i dont have friends plugins

 

Checking ruleset default for player attacking building.
Found BasePlayer attacking BuildingBlock.  Checking ruleset default, zone 0
Player has building privilege and is attacking a BuildingBlock.  Or, heli is attacking a building owned by a targeted player.
DAMAGE ALLOWED for BasePlayer attacking BuildingBlock, majority damage type Explosion
Does player saintmichel13 own wall?
  Player is friends with owner of BuildingBlock
Player has privilege to block or is not blocked by TC.

Share this comment


Link to comment

here is another example where bullet damage was allowed. i think there's a "friends" bug happening here

 

Checking ruleset default for player attacking building.
Found BasePlayer attacking BuildingBlock.  Checking ruleset default, zone 0
Player has building privilege and is attacking a BuildingBlock.  Or, heli is attacking a building owned by a targeted player.
DAMAGE ALLOWED for BasePlayer attacking BuildingBlock, majority damage type Bullet
Does player saintmichel13 own wall.low?
  Player is friends with owner of BuildingBlock
Player has privilege to block or is not blocked by TC.
Default ruleset query

Share this comment


Link to comment

i disable honor relationships and it fixed the problem. so i think there is some sort of bug in that area coz i was not friends/team/or clans in any of the bases i tested with. 

Share this comment


Link to comment

Do you have any of the useFriends, useClans, useTeams variables set to true in your config?  These are not reachable from the GUI.

Share this comment


Link to comment

i have clan and teams set as yes, but i 'm not teamed and clanned with anyone. i was able to get the effect i want by disabling honor relatinships. 

Share this comment


Link to comment

I'll be adding additional debug in the next version so that you can see which of clans/teams was returning true.  Which clans plugin?

Share this comment


Link to comment
672.6k

Downloads

Total number of downloads.

3.7k

Customers

Total customers served.

49.7k

Files Sold

Total number of files sold.

898.8k

Payments Processed

Total payments processed.

√ó
√ó
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.