Jump to content

How do I fix this?

Closed 1.1.2

Failed to call hook 'ShowKits_Page1_API' on plugin 'WPKits v1.1.2' (NullReferenceException: Object reference not set to an instance of an object)

at Oxide.Plugins.WPKits.Button_Cooldown_Text (BasePlayer player, System.String _kitName, System.String _text) [0x00032] in <2fdb9e04b46a493882d9fac68aded00a>:0

at Oxide.Plugins.WPKits.ShowKits_Page1_API (BasePlayer player) [0x00074] in <2fdb9e04b46a493882d9fac68aded00a>:0

at Oxide.Plugins.WPKits.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x006c6] in <2fdb9e04b46a493882d9fac68aded00a>:0

at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <60c318df79ed41688ea59335e48d61ad>:0

at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <9882f28dc2204b4dba514a9ad18f5042>:0

at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <9882f28dc2204b4dba514a9ad18f5042>:0

Share this comment


Link to comment
34 minutes ago, 7SINS7 said:

Failed to call hook 'ShowKits_Page1_API' on plugin 'WPKits v1.1.2' (NullReferenceException: Object reference not set to an instance of an object)

This error most of the times means that you have non existent kit name inside your WPKits config. If you still need help just message me on my discord !David#1337

Share this comment


Link to comment
1 minute ago, 7SINS7 said:

Is it possible to see a config setup for at least one kit using Rust Kits?

RustKits has ingame editor for kits, you dont need edit config 

Share this comment


Link to comment
19 hours ago, David said:

you have non existent kit name inside your WPKits config

This is 99% your problem, send me your config and I will check for you.

Share this comment


Link to comment

I did that out of frustration, 

ok updated with yours and this

Unloaded plugin WPKits v1.1.2 by David

Unloaded plugin WPKits v1.1.2 by David

Failed to call hook 'OnServerInitialized' on plugin 'WPKits v1.1.2' (NullReferenceException: Object reference not set to an instance of an object)

at Oxide.Plugins.WPKits.DownloadImages () [0x000d3] in <84fe6f0750544578b6fdbbdfb7b8cb4c>:0

at Oxide.Plugins.WPKits.OnServerInitialized () [0x00006] in <84fe6f0750544578b6fdbbdfb7b8cb4c>:0

at Oxide.Plugins.WPKits.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x00038] in <84fe6f0750544578b6fdbbdfb7b8cb4c>:0

at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <60c318df79ed41688ea59335e48d61ad>:0

at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <9882f28dc2204b4dba514a9ad18f5042>:0

at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <9882f28dc2204b4dba514a9ad18f5042>:0

Loaded plugin WPKits v1.1.2 by David

Unloaded plugin WelcomePanel v3.0.7 by David

Loaded plugin WelcomePanel v3.0.7 by David

 

Unloaded plugin WelcomePanel v3.0.7 by David

[WelcomePanel] (ADDONS LOADED) WPKits, WPVipRanks, WPWipeCycle, VoteMap

[WelcomePanel] (NOT FOUND) WPSocialLinks,

Failed to call hook 'ShowKits_Page1_API' on plugin 'WPKits v1.1.2' (NullReferenceException: Object reference not set to an instance of an object)

at Oxide.Plugins.WPKits.ShowKits_Page1_API (BasePlayer player) [0x010e0] in <84fe6f0750544578b6fdbbdfb7b8cb4c>:0

at Oxide.Plugins.WPKits.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x006c6] in <84fe6f0750544578b6fdbbdfb7b8cb4c>:0

at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <60c318df79ed41688ea59335e48d61ad>:0

at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <9882f28dc2204b4dba514a9ad18f5042>:0

at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <9882f28dc2204b4dba514a9ad18f5042>:0

Share this comment


Link to comment

Remove your config and reload plugin, then go to config and put Enabled on false for every kit. Then start filling them one by one.

Share this comment


Link to comment
15 minutes ago, 7SINS7 said:

Did all that doesn't matter it wont work, you can close it as I am over it.

Sorry but only two things can go wrong here, you either using wrong Kits plugin or you have mistake in config file. Im always available to help. If you change your mind just message.

Share this comment


Link to comment

Ok, so I walked away came back and enabled one by one, it's one of the kits, for whatever reason a certain kit kills it but when disabled the rest show up. What could possibly be doing this, there's nothing special about the kit and it shows up fine in the kits plugin.

Share this comment


Link to comment
440.7k

Downloads

Total number of downloads.

2.3k

Customers

Total customers served.

32.5k

Files Sold

Total number of files sold.

530.9k

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.