Jump to content

Previous version of plugin failed to load NextGenPVE

Closed 1.2.4

Hello, I love this plugin, but it is giving this error and I don't know what to do:

 

Previous version of plugin failed to load: NextGenPVE

(03:51:51) | Failed to initialize plugin 'NextGenPVE v1.2.4' (InvalidCastException: Specified cast is not valid.)

at System.Data.SQLite.SQLiteDataReader.VerifyType (System.Int32 i, System.Data.DbType typ) [0x000ba] in <c628cacddc184ceeb28a412d54694bf2>:0

at System.Data.SQLite.SQLiteDataReader.GetBoolean (System.Int32 i) [0x00031] in <c628cacddc184ceeb28a412d54694bf2>:0

at Oxide.Plugins.NextGenPVE.RunSchedule (System.Boolean refresh) [0x00107] in <cf13bf01c4ff4741a45c5cc9276dfd8f>:0

at Oxide.Plugins.NextGenPVE.Init () [0x00161] in <cf13bf01c4ff4741a45c5cc9276dfd8f>:0

at Oxide.Plugins.NextGenPVE.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x00447] in <cf13bf01c4ff4741a45c5cc9276dfd8f>:0

at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <60c318df79ed41688ea59335e48d61ad>:0

at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <dfcb48ea05694263bbc08e62a39c274c>:0

at Oxide.Core.Plugins.CSPlugin.HandleAddedToManager (Oxide.Core.Plugins.PluginManager manager) [0x00043] in <dfcb48ea05694263bbc08e62a39c274c>:0

Share this comment


Link to comment

I am curious what version you upgraded from.  If you have been following each upgrade from 1.2.2 to 1.2.3 to 1.2.4 there should not have been an issue as those were minor changes to add new entities.  If you like, send me your db and I can see what might be going on with it.  Or, you have the option to delete the database file if your setup isn't complicated.  I suspect that something happened with the schedule entry in one of the rulesets, even if you hadn't set one.

Share this comment


Link to comment

Hi, thanks for the help. I have installed version 1.2.4 for the first time. There were no previous versions.
After configuring the timed system I think the error comes.
I attach the .db file
The plugin is very good, it is simple and beautiful. Congratulations!
Thank you.

nextgenpve.zip

Share this comment


Link to comment

Sorry it took so long to get back to you.  I was able to load your database just fine, and the plugin loaded with no errors.

Share this comment


Link to comment
433.7k

Downloads

Total number of downloads.

2.3k

Customers

Total customers served.

32k

Files Sold

Total number of files sold.

519.6k

Payments Processed

Total payments processed.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.